2.0 Career Sites not accessible
Incident Report for Recruiting.com
Resolved
All sites are now fully functional.
Posted Jan 10, 2018 - 00:16 UTC
Investigating
Some 2.0 Career Sites are currently not accessible.
Posted Jan 10, 2018 - 00:13 UTC