Career Sites not accessible
Incident Report for Recruiting.com
Resolved
All Career Sites are fully functional.
Posted Dec 11, 2017 - 13:56 UTC
Investigating
Some Career Sites on the 2.0 platform are currently not accessible. Recruiting.com is currently investigating.
Posted Dec 11, 2017 - 13:26 UTC