2.0 Career Sites not accessible
Incident Report for Recruiting.com
Resolved
All 2.0 Career Sites are fully operational.
Posted Mar 13, 2018 - 00:10 UTC
Investigating
Some 2.0 Career Sites are currently not accessible.
Posted Mar 12, 2018 - 23:59 UTC