Recruiting.com CRM degradation of service
Incident Report for Recruiting.com
Resolved
All CRM functionality is now performing as expected.
Posted Mar 10, 2018 - 13:23 UTC
Investigating
Some CRM users may be experiencing some intermittent degradation of service. We are aware of the issue and are working diligently to resolve them.Thank you for your patience!
Posted Mar 09, 2018 - 21:11 UTC